1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Some new members aren't following the advice on posting links - please read it!
  3. If you're looking for the LostCousins site please click the logo in the top left corner - these forums are for existing LostCousins members only.
  4. Both the main LostCousins site and this forum have been upgraded to that you can log-in securely. If you are not automatically taken to the secure site simply add https:// at the beginning of the URL.
  5. Guest - have you tested your DNA with Ancestry? Do you have English or Welsh ancestors, and do you know which counties most of them came from? If so please take part in my project by completing the NEW spreadsheet and uploading the results
  6. Only registered members can see all the forums - if you've received an invitation to join please register NOW!

Mac version 1.2.0 Build 49

Discussion in 'Family Tree Analyzer' started by Alexander Bisset, Feb 3, 2019.

  1. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    The year is a typo. So used to UK ones ending in a 1.

    The name containing an accented character is a filter that Peter has applied to the website. I’ve recently updated the app to filter a-z too. To fix both Peter and I would need to fix the website and FTAnalyzer respectively to allow accented characters.
     
    Last edited: Feb 9, 2019
  2. Helen7

    Helen7 LostCousins Star

    Unfortunately, that's not the problem. The program drops out after a few seconds of the 'Started Processing Lost Cousins entries' message. As the display disappears, there is no error message visible and clearly the program is no longer running so it won't upload even if I leave it forever! No crash report is produced for me to send to Alexander to analyse what went wrong. It is annoying, as it works perfectly for my husband's file (created by me in exactly the same way) but not mine.

    I noticed the 7 new 'blood relative' entries I was trying to upload were all from my maternal grandmother's branch, so I created a GEDCOM of that branch and tried that, but got the same outcome. Obviously, I can upload these entries manually to LC in a few minutes, and all the other aspects of FTA seem to work fine, but it's the principle of this failure to upload that's annoying, as I can't see what's going wrong. I can't see any problem with the census references for these 7 individuals - they are all from the 1841 or 1881 England & Wales census, and FTA reports no invalid references - so I am at a loss to explain the problem.

    I noticed when checking the FTA-uploaded entries for my husband's relatives that the dates of birth and names entered are the actual ones, not those appearing in the censuses (often a year or two out, middle names added, different spellings), so needs a bit of tweaking to match the census (or transcript in 1881 - even if that's wrong). I think others have commented on these differences in the main thread, so probably not something that can be automated. Though I do wonder about the maiden names being put into the 'corrected surname' field - surely that is not necessary?
     
  3. peter

    peter Administrator Staff Member

    Currently only characters from the English alphabet are allowed in the names of relatives - this is the first time this issue has been reported.
     
  4. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Hi Helen,

    I've got a new Build 46 out now. This brings it into line with the Windows code updates so all the various fixes so far. There are others I need to tweak - maiden name in corrected field is one such mistake.

    The small variants of age and name are an issue and is precisely why Peter has specified that users must check the entries after upload. It's why the program gives you a warning message to check and why in a future version it will show you a checklist with the links and will highlight the ones you haven't yet clicked to check.

    This is the best we can do nudges to encourage best behaviour. Just as any program can ask users to put information in a field some users deliberately bypass that by entering a dot or something. We code for the users that want to help themselves and encourage the lazier ones but cannot thwart those determined to bypass checks.

    The tools are being built to assist as best as possible as ever it is up to the individual user to make sure their data is correct. I did look at ways of reading the links but it seems that FMP go to great lengths to prevent automation and Peter has expressed a concern that automatically processing so many links on the FMP site at once may breach the contract to use the links. So alternate means to help users verify your data are being implemented.

    As ever it is only by the wonderful assistance of users such as yourself, Jorghes and others on the Mac and Tim, Brian, Andrew, David and others on the PC that this new facility is being implemented. The downside is you suffer a few teething problems during implementation. I do try to keep such things to a minimum but you are all so good at finding little tweaks :):)
     
  5. Helen7

    Helen7 LostCousins Star

    Thanks, I've just downloaded this new build and tried it. However, having logged in successfully (and confirmed myself as root person), the 'Update Lost Cousins site' button does not appear! (it did on the previous version)
     
  6. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Oh ok I'll investigate why not.
     
  7. Alexander Bisset

    Alexander Bisset Administrator Staff Member

  8. Helen7

    Helen7 LostCousins Star

    Thanks. I am just on my way out now but will download the new version and try it out later.
     
  9. Helen7

    Helen7 LostCousins Star

    I have just tried the new build, and the 'Update Lost Cousins site' button is now available. I tried it with my tree, but got the same crash as before.

    I then tried it with my husband's updated tree, and it reported 3 possible records to upload to Lost cousins.
    However, on clicking the upload button, I got the following message for 2 of the 3 records:

    Problem accessing Lost Cousins website to send record below. Error message is: AppKit Consistency error: you are calling a method that can only be invoked from the UI thread.
    (followed by details of the record it failed to add)
    The other record it said was already present (which on checking, I find is correct)

    Then underneath it reported:
    Finished writing Entries to Lost Cousins website: 0 successfully added, 1 already present, 0 possible duplicates and 2 failed.

    I have checked the LC site for the 2 'failures' and can confirm they weren't uploaded. I don't understand the error message, as I've no idea what AppKit Consistency or UI thread are, though no doubt you'll recognise these terms, Alexander - can you suggest what might be going wrong?
     
  10. Helen7

    Helen7 LostCousins Star

    I went back to build 45 and uploaded the 2 new entries mentioned in my last message to LC without any problems.
     
  11. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Yes what's wrong it's trying to update something on page using the background processing task rather than the foreground one.
     
    Last edited: Feb 13, 2019 at 8:09 PM
  12. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Helen would it be at all possible to send me the GEDCOM file that's failing so I can load it and discover why? Email is best ftanalyzer@gmail.com
     
  13. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Build 49 now available should fix AppKit error.
     
  14. Helen7

    Helen7 LostCousins Star

    Thanks, I've tried this and it works fine with my husband's tree - no error messages and new entries uploaded to LC with no problems. And I see the maiden names are no longer going into the 'corrected surname' box, so that's great.

    I still have the same problem as before with my tree, i.e. crashing out of the program with nothing uploaded to LC. I'll e-mail you the GEDCOM for this.
     
  15. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Thanks got the file - oddly it's not crashing on my machine :(
     
  16. Alexander Bisset

    Alexander Bisset Administrator Staff Member

  17. Helen7

    Helen7 LostCousins Star

    Hi Alexander
    Trying this GEDCOM again (with build 50), the 'Started Processing Lost Cousins entries' message shows for 4 seconds, then another message appears very fleetingly (far too quick to read!) just before it crashes. So I did a screen recording, and stepping through the frames allowed me to read the error message below:
    Problem accessing Lost Cousins Website to read current ancestor list. Error message is: startIndex cannot be larger than length of string.
    Parameter name: startIndex


    I don't really know what this means, but it looks like the problem lies not with the GEDCOM but with my Ancestors list at LC. Is my list too big? According to my Summary page, my ancestors list comprises:

    England & Wales 1881 893
    England & Wales 1841 362
    England & Wales 1911 911
    Scotland 1881 7
    United States 1880 17
    United States 1940 2
    TOTAL 2192


    As Peter has suggested previously, I have followed my ancestors' families from the 1841 census to 1881 and 1911 so have ended up with lots of census records and built up a large list over the years! By comparison, my husband's list is only 758 records long and FTA had no problem accessing that.
     
  18. jorghes

    jorghes LostCousins Member

    I don't think so Helen, I've never really had much of a problem, and my summary reads:
    England & Wales 1881 1799
    England & Wales 1841 594
    England & Wales 1911 1929
    Scotland 1881 175
    Canada 1881 64
    United States 1880 120
    United States 1940 723
    TOTAL 5404
     
  19. Helen7

    Helen7 LostCousins Star

    Thanks, jorghes, I thought you would have a large number of entries!

    Knowing that size of the ancestors list was not the problem, I looked through my list to look for anomalies and found one! I had 3 people without forenames entered, as they were illegible on the 1841 census - FMP had them indexed as ???, and though Ancestry's transcription listed the forenames, I couldn't read them on the original so entered them on LC with no forename (I put a . there as Peter recommended for infants, though these weren't infants).

    Anyway, I have now deleted those entries and re-run FTA and guess what? It works!! All uploaded to LC with no problems.

    Apologies, Alexander, I should have checked my ancestors list more closely. However, it does indicate that entries without forenames may cause a problem for others auto-uploading.
     
  20. Helen7

    Helen7 LostCousins Star

    And the further good news is that the 7 new blood relatives I have just entered using FTA all match with a new cousin! Just about to contact them now...

    Thanks again Alexander - wonderful tool!
     

Share This Page