1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Some new members aren't following the advice on posting links - please read it!
  3. If you're looking for the LostCousins site please click the logo in the top left corner - these forums are for existing LostCousins members only.
  4. Both the main LostCousins site and this forum have been upgraded to that you can log-in securely. If you are not automatically taken to the secure site simply add https:// at the beginning of the URL.
  5. Guest - have you tested your DNA with Ancestry? Do you have English or Welsh ancestors, and do you know which counties most of them came from? If so please take part in my project by completing the NEW spreadsheet and uploading the results
  6. Only registered members can see all the forums - if you've received an invitation to join please register NOW!

Mac version 1.2.0 Build 49

Discussion in 'Family Tree Analyzer' started by Alexander Bisset, Feb 3, 2019.

  1. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Hi all

    The Mac version is close to being ready to release and it includes the ability to upload your entries you are missing to Lost Cousins. Prior to launching it on the App Store it would be useful if any Mac beta testers could try it out and give feedback on the use of it. Particularly any rough edges or bugs that need addressed.

    You can find the beta here
     
  2. jorghes

    jorghes LostCousins Member

    Will happily trial it for you... I should still have people left to add!
     
  3. jorghes

    jorghes LostCousins Member

    It allows you to view the Potential Uploads to Lost Cousins, and those with Invalid Census Refs, but has no "Update Lost Cousins" button, and the Verification page is blank.

    No wait... I had to make it Login again for the "Update" button to appear.
     
  4. Helen7

    Helen7 LostCousins Star

    Thanks, I'll definitely try this out later today, after I've finished checking my manual LC entries!
     
  5. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Yes you need to login and confirm the root person (to make sure the relationship blood/married/direct is right) before the button becomes active. The verification tab is a work in progress, I thought I'd told it to hide :) So I'll fix that and make it clearer login is required.

    Thanks this is exactly the sort of little things that I miss but could do with a tweak to make for a more polished program.
     
    Last edited: Feb 3, 2019
  6. jorghes

    jorghes LostCousins Member

    It was working well, I'm glad to see the LC fact lists on the Mac version, I've been waiting for that - means that I don't have to continually switch between my home Mac and occasionally my work PC.
     
  7. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Thanks for the feedback. I'm fairly close to being able to submit to Apple for updating on App Store. However because of the hoops of submitting I don't want to have to tweak something later. On the windows version I can make a change then release a new version on a whim. On the Mac version I find myself holding back in case there's an issue as it takes days instead of minutes to issue a fix since everything goes via Apple.
     
  8. Helen7

    Helen7 LostCousins Star

    Well, I've tried this and really like the interface with the LC fact lists. However, when I tried to upload the 7 blood relatives identified (correctly) as not having been uploaded to LC, it failed. I tried this 3 times with the same result. Below is the procedure I used. Am I doing something wrong?

    Including all relationship types showed 70 possible records to upload to LC, but most of these were 'by marriage'. I decided to try uploading the blood relatives first, and unchecked the other boxes, which reduced the number to 7. I logged in (login confirmed as successful) and confirmed the root person. Clicking the 'view potential uploads' listed the correct people, and 'view invalid refs' showed no invalid refs for these. When I clicked on 'Update to Lost Cousins site' I got the pop-up message 'You have 7 possible records to add to Lost Cousins. Proceed?'. So far, so good.

    However, when I clicked 'Yes' to proceed, it displayed 'Started processing Lost Cousins entries' but then after about 5-10 seconds crashed out of the program without uploading anything to Lost Cousins.

    Any ideas what has gone wrong? Could it be because I restricted the upload to blood relatives only? I haven't tried uploading the rest yet (thought I'd start small to try it out!).
     
  9. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Hmmm odd. All sounds right.

    So it didn't put any error messages up at all? Someone pointed out it isn't actually using the relationship filter at present I'll add that in. So it couldn't be that.
     
  10. jorghes

    jorghes LostCousins Member

    Did it actually fail? I frequently get a "Failed" notice when the record has, in fact, been uploaded to Lost Cousins. The first time I ran it with the Mac program, it "failed" two entries, but at least one (I think maybe both, it was late last night) were entered correctly onto Lost Cousins as they were clearly in the list!
    (I have had this "failed but not really" issue with both the PC and Mac programs, and it seems fairly random as to which have actually failed and which were uploaded even though it says it failed.)
     
  11. Helen7

    Helen7 LostCousins Star

    I didn't get a 'Failed' notice - or any other error message. The FTA screen just disappeared within seconds of displaying the 'Started processing Lost Cousins entries' notice.

    I then logged into LC in my usual browser and looked for the people I had been trying to add, but none of them appear in my 'My Ancestors' list.
     
  12. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Ok then it crashed there will be a crash log recorded. If you are unsure how to get it I can tell you once I finish my journey to Spain as laptop is packed away now till Tuesday. Or you could google “Mac application crash log location”

    What version of MacOS are you running?
     
    Last edited: Feb 4, 2019
  13. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    My problem is that the website usually throws back a failure message as it would with a manual user. I’ve yet to see this failed but didn’t record myself. If you can identify anyone who fell into that category and can send me a GEDCOM of that person I can have a look to see why it might have failed. Or at least why it might have thought the website said failed.
     
  14. jorghes

    jorghes LostCousins Member

    Possibly not, I don't think I can remember who it was! It happens to me fairly frequently - if it helps, the majority of those who "fail" are said to have correct census returns. The last lot which had an upload/fail combination were from the 1940 US census.

    I will try though I will look tonight and try to locate some that it may have said failed.
     
  15. Helen7

    Helen7 LostCousins Star

    No crash log that I (or my husband, who knows about such things) can find. We found a few other crash logs, but nothing for this.

    I am running MacOS High Sierra 10.13.6.
     
  16. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Thanks. The Folder you are looking for is Library/Logs/DiagnosticReports/

    To get to the library folder use Finder App and hold down Command Key and click Go menu you will then see as below. Note that the Library menu is hidden normally this is why you need to hold down the Command Key to see it.
    upload_2019-2-4_12-19-46.png

    Once you have the library folder open browse to Logs and then diagnostic reports. You should see files with names like this...
    upload_2019-2-4_12-22-29.png

    If you send me any FTAnalyzer ones from that to ftanalyzer@gmail.com I can investigate further.
     
  17. Helen7

    Helen7 LostCousins Star

    Thanks for these detailed instructions which I've followed, but the DiagnosticReports folder does not contain any FTAnalyzer files at all (just 3 others dating from January). So it's a bit of a mystery.

    I plan to try again, using FTA to upload some records from my husband's tree, so will see if I get the same problem. I will let you know the outcome.
     
  18. Alexander Bisset

    Alexander Bisset Administrator Staff Member

    Thanks. Yes quite the mystery. This sort of effect is usually caused by the program suffering a fatal crash and unable to continue which is why I expected a diagnostic log. I'll need to read up on the Mac to see if there are ways I can globally trap such problems.
     
  19. Helen7

    Helen7 LostCousins Star

    Success!!

    I used FTA with my husband's tree (which I also manage) and it worked fine, 43 'new' people uploaded to LC in a matter of seconds, no problem. As before, I initially uploaded the blood relatives, then went back and did the 'by marriage' people and it all worked fine, with the progress log listing all the entries and confirming no failures, then taking me straight to the 'My Ancestors' list on LC with new FTA-added entries nicely flagged.

    I have not noticed any duplicates. However, the maiden name of any married woman is entered as a 'corrected surname' (as well as maiden name) so it appears in the list as her surname in italics, so I need to go and remove these amended surnames, which is a bit annoying.

    Still no idea why it doesn't want to upload my relatives (I never even saw a progress log with that), as I didn't do anything different. Must be something wrong with the GEDCOM. I'll go back and have another go from scratch.

    Thanks again.
     
  20. jorghes

    jorghes LostCousins Member

    Just another note - In the Lost Cousins section (before hitting the "Update" button), there are two references to the Canadian census- the one in the list on the right hand side says "1881", while the button the left says "1880".

    Perhaps a typo?

    I also have a 1940 US census entry which fails every time - I'm wondering if it's because his name contains a letter which doesn't exist in the normal English alphabet? it is the "ø". I've attached a GEDcom with him in it so you can see if it's anything else!

    Helen - occasionally it can take a while for the upload to start - I have noticed that it can sit on "Started processing Lost Cousins entries" for longer than you think it should. Perhaps for yours you just need to get it started and leave it for while, and see if that's the problem?
     

    Attached Files:

Share This Page